Ubuntu系统下Angularjs开发环境安装,Ubuntu系统建立Rail开发环境和安装RMagic

Ubuntu怎么也是个Linux,辛亏一向用mac
系统已经习贯了命令行格局,各样东西照旧相比较顺手的,小编吗,当然只为了搭
Rails情况才安的,从昨日安好Ubuntu到前些天,一共安了6次系统,可怜啊,,幸亏,,以后终于化解了,,

https://gorails.com/setup/ubuntu/14.04

刚才试了弹指间,相当轻便。就当是给入门级的叁个课程好了。

一.win7条件下安装ubuntu系统

安装Rails

1.Installing Ruby
先是须求安装Ruby的局部凭仗:

瞩目:那篇小说只介绍怎么着在
Ubuntu 12.04 Server
上设置 Rails 情况,不保险你的 Rails 项目必然能够在 12.04 上健康运作。

 


sudo apt-get update
sudo apt-get install git-core curl zlib1g-dev build-essential libssl-dev libreadline-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt1-dev libcurl4-openssl-dev python-software-properties libffi-dev

正文测量检验遭遇

 注意:在装置的第四步选拔“安装ubuntu系统,与win7系统共存”这一项,那样可以防除后边的分区,安装更有利于

sudo apt-get install build-essential gcc g++ libssl0.9.8 libssl0.9.8-dbg
libssl-dev build-essential

**2.Using rbenv to manage ruby **
安装以及布署rbenv,并用rbenv安装ruby

Ubuntu系统下Angularjs开发环境安装,Ubuntu系统建立Rail开发环境和安装RMagic。装的连串是: Ubuntu 12.04 Server LTS amd64

二.安装jdk8

sudo apt-get install ruby

git clone https://github.com/rbenv/rbenv.git ~/.rbenv
echo 'export PATH="$HOME/.rbenv/bin:$PATH"' >> ~/.bashrc  #用zsh的改为.zshrc,下面也是
echo 'eval "$(rbenv init -)"' >> ~/.bashrc
exec $SHELL

git clone https://github.com/rbenv/ruby-build.git ~/.rbenv/plugins/ruby-build
echo 'export PATH="$HOME/.rbenv/plugins/ruby-build/bin:$PATH"' >> ~/.bashrc
exec $SHELL

rbenv install 2.3.1
rbenv global 2.3.1
ruby -v

#使用rbenv安装ruby时会因为源的问题速度很慢,甚至多次安装失败,可以通过从国内的源下载ruby源码压缩文件
#然后放入~/.rbenv/cache文件夹中,最后运行rbenv install 2.3.1来进行ruby的安装
#国内ruby下载源#https://ruby.taobao.org/mirrors/ruby/

安装于: OSX 上 Parallels Desktop 虚拟机

 

sudo apt-get install rubygems

rbenv常用命令如下:

Ubuntu 安装

 注意:配置文件改为在~/.bashrc里面参预

sudo gem update –system

rbenv install ...
rbenv global ...   #这条命令是设置全局ruby版本,可用于所有的shell,
#它是通过在~/.rbenv/version中写入版本号实现的,也可以通过设置RBENV_VERSION环境变量来实现
rbenv local ... #这条命令是设置当前目录的ruby版本,一般可用于某一个项目中,执行这条命令之后,
#会在当前目录生成一个ruby-version文件,并且将版本号写入这个文件
rbenv local unset   #撤销当前目录设置的ruby版本
rbenv versions   #列出所有rbenv安装的ruby版本
rbenv version   #当前所使用的ruby版本
rbenv rehash  #用于为所有ruby安装shims,一般用于安装了新版本的ruby或者提供了命令的gem之后

很广阔的装置:

export
JAVA_HOME=/home/liwh/Tools/jdk1.8.0_31
PATH=$JAVA_HOME/bin:$PATH

sudo gem install Rails
(上面是英特网写的格局,可作者怎么就在那步停住了,无法,作者要好下了2.2.2的GEM相关包,直接本地安装了,认为没有错)

3.Installing Bundler

选择 English 安装

境况变量生效

sudo gem install mongrel

gem install bundler
rbenv rehash

Location 选择 other -> Asia -> China

      source ~/.bashrc

sudo apt-get install libgd-ruby1.8 libyaml-ruby libzlib-ruby

4.Installing Rails

接二连三设置,一路暗许。。

三.安装intellij IDE14

sudo apt-get install imagemagick

#先要安装rails的依赖nodejs
curl -sL https://deb.nodesource.com/setup_4.x | sudo -E bash -
sudo apt-get install -y nodejs

#ps:安装nodejs时,会因为apt-get源的问题安装很慢,可以通过System Settings - Software & Updates - Download from
#设置为中国的源来解决问题

gem install rails -v 4.2.6
rbenv rehash
rails -v 

输入人名、用户名和密码

  1.下载intellij
IDEA14,下载地址为:

sudo apt-get install libmagick9-dev ruby1.8-dev(这里会报错,不用管)

5.Setting up MySQL
设置mysql的经过中会被须要输入密码,这些密码在布署database.yml文件中须求被用到

Write the changes to disks and configure LVM? <Yes>

  2.下载前置放自身的文件夹,解压到当前目录就可以